Author Topic: Error 505 installing LHBP Build 15 on new computer - P4Dv4.5  (Read 375 times)

Offline chasordod

  • Jr. Member
  • **
  • Posts: 17
Error 505 installing LHBP Build 15 on new computer - P4Dv4.5
« on: August 04, 2019, 15:46:27 PM »
Hi,

Installed LHBP on a new computer (Windows10 - P3Dv4.5) which seemed to complete correctly with scenery working OK.

Every time I start P3D, though, I get an error message "Error 505 - LHBP scenery genuine test failed. Please contact LHSimulation support"

If I check the LHS line in the simulator addons menu, it confirms valid key code for version 1, but invalid code for version 2. Since I only have version 1, until version 2 is released, could you tell me how to get rid of the error message on startup?

Thanks,

Charles

Offline tsGucci

  • Administrator
  • Hero Member
  • *****
  • Posts: 4.479
    • LHSimulations
Re: Error 505 installing LHBP Build 15 on new computer - P4Dv4.5
« Reply #1 on: August 05, 2019, 16:44:40 PM »
Hi


To simply get rid of the message you need to delete the LHBP_objectPlacer.dll from your Modules folder. But in this case the scenery will not work.
I think the scenery should be reinstalled.

Lima Hotel Simulations - Flight Simulator scenery design for Hungary

Offline chasordod

  • Jr. Member
  • **
  • Posts: 17
Re: Error 505 installing LHBP Build 15 on new computer - P4Dv4.5
« Reply #2 on: August 05, 2019, 18:32:18 PM »
Hi,

Thanks for getting back to me.

I should add that I am just finishing the process of moving my P3D addons from old PC to new PC. LHBP was installed on my old PC. It was uninstalled from old PC. I have tried uninstalling and reinstalling on new PC.  Both appear to work perfectly through all stages.

Sadly, I still get the error 505 on starting P3D. Scenery displays as it should, however.

On opening the LHBP section in the simulator addons drop-down menu, I still get success indicated for LHBP, but failure for LHBP v2. Why is a version 2 check done on a version 1 installation? Is it this causing the problem?

Is there something I'm missing in transferring product from an old to new PC? I have quite a collection of scenery and aircraft products, but no others have caused any difficulty in transferring.

Happy to do any diagnostic digging that you think might help.

Charles




Offline tsGucci

  • Administrator
  • Hero Member
  • *****
  • Posts: 4.479
    • LHSimulations
Re: Error 505 installing LHBP Build 15 on new computer - P4Dv4.5
« Reply #3 on: August 05, 2019, 20:23:38 PM »
Dear Charles.


Strange because if you install it on the new computer it should be fine. The LHBPv2 does not disturb at the moment.
What does it say in the AddOn menu for v1?

Could you please send us some logs. Follow this video please:
http://lhsimulations.com/forum/index.php?topic=436.0

Lima Hotel Simulations - Flight Simulator scenery design for Hungary

Offline chasordod

  • Jr. Member
  • **
  • Posts: 17
Re: Error 505 installing LHBP Build 15 on new computer - P4Dv4.5
« Reply #4 on: August 05, 2019, 21:06:04 PM »
Hi,

Addon Menu entries for v1

LHBP is installed according to CFG
LHBP registry entry is OK
LHBP user product key is valid

Will logs to you tomorrow - have to be sociable, now.

Charles

Offline chasordod

  • Jr. Member
  • **
  • Posts: 17
Re: Error 505 installing LHBP Build 15 on new computer - P4Dv4.5
« Reply #5 on: August 07, 2019, 10:51:18 AM »
Hi,

Log sent, as requested.

Charles

Offline szilard92

  • Beta tester
  • Newbie
  • *****
  • Posts: 1
Re: Error 505 installing LHBP Build 15 on new computer - P4Dv4.5
« Reply #6 on: August 08, 2019, 08:13:26 AM »
Dear Charles,

Thanks for the logs, We identified the problem and applied a fix in our newest dll build (version 1.4.0.16). I attached the newest dll to this post, because it is not yet available on our server. It would be helpful if You could verify if it's really fixed the problem in your case. Unzip and copy this dll to your Prepar3D v4/Modules folder.

The link for the dll: https://drive.google.com/open?id=12LgMZRaKfwdiLO4f6AvfxUKmUn4IAZcb
« Last Edit: August 08, 2019, 08:22:19 AM by szilard92 »

Offline chasordod

  • Jr. Member
  • **
  • Posts: 17
Re: Error 505 installing LHBP Build 15 on new computer - P4Dv4.5
« Reply #7 on: August 08, 2019, 10:46:44 AM »
Hi,

That's fixed it - all working as it should.

Presumably, I can get rid of the simconnect log running in the background on startup by running the configurator again?

Many thanks,

Charles

Offline tsGucci

  • Administrator
  • Hero Member
  • *****
  • Posts: 4.479
    • LHSimulations
Re: Error 505 installing LHBP Build 15 on new computer - P4Dv4.5
« Reply #8 on: August 08, 2019, 12:57:50 PM »
Hi,

That's fixed it - all working as it should.

Presumably, I can get rid of the simconnect log running in the background on startup by running the configurator again?

Many thanks,

Charles
Thank you very much for your cooperation!
Yes. Run the configurator and disable the log options.
« Last Edit: August 08, 2019, 13:15:52 PM by tsGucci »

Lima Hotel Simulations - Flight Simulator scenery design for Hungary